Working with the OpenTM2 Editor

Contents

What the OpenTM2 editor is

OpenTM2 has a built-in editor that assists you when translating. It supports all major editing functions and a set of functions that are especially adapted to translations.

You can work with the editor when you have entered the Translation Environment.

The descriptions in this chapter apply also to the Rich Text Format editor RTFEdit, which supplements the standard editor in support of Thai language documents. See also Working with Thai language documents, if required.

Basic functions

Usually when you want to do a certain task with OpenTM2’s editor, you select a menu that takes you to a window where you fill in the required information. For some basic editing functions OpenTM2 offers you predefined key combinations that you can reassign to suit your individual needs. This is a quick way of performing tasks that you do frequently.

Assigning keys

For some functions you can define your own keys or key combinations by selecting Keys… from the Options menu. In the “Assign Keys” window select the function you want to define a key for. These are the functions for which no menu commands are available and no keys have been predefined. In the “Assign Keys” window they are indicated by *none*.

Click Assign new key. You are prompted to press the key or key combination you want to assign to a function. Then click Assign to save your settings and leave the window.

Clicking Print lets you print all functions and their assigned keys.

To remove a key assignment, click Clear key in the “Assign Keys” window after you have selected a function.

The Appendix: Editor functions reference gives you an overview of the tasks to which you can assign keys.

Finding and replacing terms

If you wish to locate a specific term in your translation document, select Find and Replace… from the Edit menu in the Translation Environment. In the “Find and Replace” window type the word you are looking for in the Find field and click Find. You can define the following search criteria:

  • The spelling of the term to be searched (case sensitivity)
  • The direction of the search (forward or backward)
  • The text area that can be changed: within the current segment if the document is currently being translated, or throughout the file if the document is currently being revised (post-edited)

A term is found even if it spans over two lines.

If you wish to replace a word by another term, type the new term into the field Change to and click Replace. The term specified in the Find field is changed to the new term in all places where it has been found in the text. If you wish to change the term only in certain contexts, click Confirm on changes. When the term is found press the Replace button a second time to replace the found term.

If you wish to locate a certain piece of text but do not know exactly the document where it originates from, you can search through a series of documents related to a folder. See Searching and replacing text in documents for details.

The “Find and Replace” window remains open until you explicitly close it and is associated with the window that is currently active.

If both the “Translation” window and the “Original” window (source document) are open during a search, the two windows are synchronized. This means that when the searched term is found in the “Translation” window, the “Original” window is scrolled to the segment that contains the source of the searched term, and vice versa.

If you close the “Find and Replace” window and open it again at a later point of time during the same OpenTM2 session or during a new session, the Find and Change to lists contain the last five terms that you searched for and changed.

Searching for terms in Translation Memory databases

The function Concordance search allows to search through one or more Translation Memory databases for terms. This function is useful to search for other translations of the given term or to verify the context of translations.

The concordance search is activated from the Edit pulldown menu of the Translation Environment.

The concordance search window is a modeless window which can be opened parallel to the other windows of the Translation Environment; i.e. you can work in the translation window without having to close the concordance search window.

The window can be positioned everywhere on the desktop and its size is customizable.

Prerequisites

The “Translation Environment” is active.

Calling sequence

Select: Concordance Search… from the Edit menu

The “Concordance Search” window is displayed.
ConcordanceSearch.gif

Figure 18. Concordance Search window

Options and parameters
  • Term(s)
Enter here the term being searched for. This field is preset with the contents of the clipboard. The term is exactly searched like it has been specified in this field.
  • Source
When selected the search is done in the source of the memory proposals.
  • Target
When selected the search is done in the target of the memory proposals.
  • Primary memory
Check this option to search the primary memory. The primary memory is the memory active for the current document. The name of the primary memory is displayed in parenthesis following the text “Primary memory”.
  • Additional Memories
Check this option to select other memory databases. When this option has been active additional memory databases can be selected by pressing the “Change” button.
  • Change
Press this button to activate the memory selection dialog and select one or more memory databases for the search.
  • Ignore case
When selected the search is performed case insensitive otherwise is it performed case sensitive.
  • Results
The search results are shown in this area. Each found proposal starts with a delimiter line containing the document and segment number of the memory proposal followed by the source of the proposal and the target of the proposal. The matching portions of the text are colored in yellow.
  • Find in result area
Enter here the text which is to be searched in the result area.
  • Find
Press this button to start the search for the entered text. Each time the button is pressed the next occurrence of the text (if any) is selected. At the end of the result area the search restarts at the beginning of the result area.
  • Search
Press this button to start the search. The button is only active when some text has been entered in the Term(s) field and when at least one search memory has been selected. The button becomes inactive while the search is performed.
  • Stop search
This button is only active while a search is running. Press the button to stop the current search and to enter the search criteria for a new search.
  • Cancel
Press this button at any time to close the concordance search window.

Moving around the text

When you have opened a document you can start using the editor. The text appears in the “Translation” window, and the cursor is placed in the active text unit to be translated (shown with a yellow background). To view another part of the text in the “Translation” window, you must move the cursor. The following table explains how to move the cursor within a segment and within the complete translation and how to scroll text in windows.

Move to… Action Comment
Active segment Translate menu, “Go to active segment” Positions the cursor in front of the first character of the active segment.
Beginning of line Home Positions the cursor at the beginning of the current line.
Beginning of segment Alt+Home Positions the cursor at the beginning of the current segment.
Bookmark Translate menu, “Go to bookmark” Positions the cursor on the bookmark previously set. To go to subsequent one, repeat action.
Bottom of document Ctrl+End Moves cursor to bottom of document.
End of line End Positions the cursor on the last character of the current line.
End of segment Alt+End Positions the cursor on the last character of the active segment.
Newly translated segment To be assigned Saves you from scrolling through whole text. Takes you directly to the segment.
Next changed segment To be assigned Saves you from scrolling through whole text. Takes you directly to the segment.
Next line Enter Positions the cursor at the beginning of the next line.
Next unchanged segment To be assigned Saves you from scrolling through whole text. Takes you directly to the segment.
Next untranslated segment Translate menu, “Next untranslated segment” Confirms a translation and positions the cursor in the next untranslated segment.
Next word Ctrl+Right Positions the cursor on the next word.
Previous word Ctrl+Left Positions the cursor on the first character of the previous word.
Tab backward Backtab Moves cursor to previous tab stop (tab = 8 characters).
Tab forward Tab Moves cursor to next tab stop (tab = 8 characters).
Top of document Ctrl+Home Moves cursor to top of document.
Scrolling
Scroll… Action Comment
Dictionary proposal down Alt+down Moves text 1 line down.
Dictionary proposal up Alt+up Moves text 1 line up.
Translation down Shift+F4 Moves text 1 line down.
Translation left Shift+F5 Moves text 1 character to the left.
Translation right Shift+F2 Moves text 1 character to the right.
Translation up Shift+F3 Moves text 1 line up.
Translation Memory proposal down Ctrl+down Moves text 1 line down.
Translation Memory proposal up Ctrl+up Moves text 1 line up.
Translation down Page Down Moves text 1 page down.
Translation up Page Up Moves text 1 page up.
Querying and setting the cursor position

Use the options Query line or Go to line… from the Cursor menu in the Translation Environment to query the line where the cursor is located or to move the cursor to a certain line within your document.

Moving around marked text

To copy, move, or delete a section of text within a segment, the OpenTM2 editor provides key combinations. Selecting a section of the text is called marking. You can mark text across several segments or lines. Marked text is displayed in reverse image.

To work with a text section:

  1. Mark the text to be copied, moved, or deleted by using the respective key combination. The OpenTM2 editor highlights the area to show you what you have marked.
  2. Move the cursor to the position where you want to copy or move the highlighted text.
  3. Use the respective key combination depending on what you want to do with the marked text (copy, move, or delete).

To manipulate a block of text, use one of the following key combinations:

Task Action Comment
Copy block To be assigned Copies a marked text section to the current cursor position.
Copy block to clipboard Ctrl+Insert Copies a marked text section to the Windows (R) clipboard.
Copy proposal block to clipboard Ctrl+letter of proposal Copies a marked Translation Memory proposal, or part of it, to the active segment in the “Translation”window. Marking is only possible within one proposal. If you specified line wrapping for this translation, the copied text is also wrapped.
Cut block to clipboard Shift+Delete Copies a marked text section to the Windows (R) clipboard and then removes the block.
Delete block Key or command to be assigned Removes a marked text section.
Find block Cursor menu, “Find block” Moves cursor to marked text section.
Mark block Shift+Cursor, or mouse Marks a text section.
Mark word Key or command to be assigned Marks the word where the cursor is positioned.
Move block Key or command to be assigned Moves a marked text section to another position.
Paste block from clipboard Shift+Insert Inserts marked text section from clipboard into text.
Unmark block Edit menu, “Unmark block” Removes marking from text section.

Note:

  • Only the active segment or, if in postediting mode, translated segments can be cut to the Windows (R) clipboard.
  • Marked areas can only be moved within the active segment or, if in postediting mode, the translated segments.
  • When copying text, remember that a segment can have a maximum size of 2 KB.

Working with bookmarks

OpenTM2 lets you set bookmarks in a text to temporarily indicate a place where you want to return to later.

Task Key or Menu Comment
Set bookmark Translate menu, “Set bookmark” Sets a bookmark at the current cursor position. Makes it easier to return to this point in text later to complete the translation, for example.
Go to bookmark Translate menu, “Go to bookmark” Moves cursor to the position where you set a bookmark.
Clear bookmark Translate menu, “Clear bookmark” Removes a bookmark previously set.

Working with lines and words

The OpenTM2 editor provides default key combinations for manipulating lines and words within a document.

Task Key or Menu Comment
Delete character Delete or Backspace key Deletes the character where the cursor is currently positioned, or the previous character.
Delete line To be assigned Deletes the line where the cursor is currently positioned.
Delete until tag To be assigned Deletes all characters from the current cursor position up to the next tag.
Delete word To be assigned Removes the term where the cursor is located.
Find and replace Edit menu, “Find and replace” Locates the required term and replaces it as specified.
Insert line To be assigned Inserts a line after the line where the cursor is currently positioned.
Join lines To be assigned Joins the current line with the following one.
Split line To be assigned Splits the line at the current cursor position.
Truncate line Ctrl+Delete Deletes all characters from the current cursor position until the end of the line.
Undo Alt+Backspace Restores the original state as it was before an action was performed. You can undo up to five preceding operations.
Wrap line Edit menu, “Line wrap (toggle)” Set wrapping at margin column on or off.

Translation-specific functions

The OpenTM2 editor particularly supports you when you translate in the Translation Environment.

Task Key or Menu Comment
Add an abbreviation Translate menu, “Add an abbreviation” Adds the term where the cursor is positioned to your abbreviation list.
Automatic substitution Translate menu, “Automatic substitution” Replaces segments for which a translation has been found in the Translation Memory by their previous translation. Automatic substitution stops when no exact match or more than one exact match has been found.
Change display style of markup tags Displays the markup information in a document according to the selected style. To avoid overtyping by mistake, all markup tags are protected by default.
Copy dictionary proposal Ctrl+letter of proposal Inserts the translation proposal at the current cursor position. The first 26 dictionary entries are preceded by a to z, the entries 27 to 52 are preceded by A to Z. Entries beyond 52 are preceded by an asterisk (*) and must be copied from the clipboard using Copy and Paste.
Copy Translation Memory proposal Ctrl+number of proposal Replaces the active segment with the translation proposal. See Moving around marked text for information on how to copy a marked part of a translation proposal.
Delete Translation Memory proposalproposals “Delete” key while cursor is on proposal Lets you remove translation proposals from the Translation Memory, for example, translations that have been added by mistake.
Display exactfuzzy proposals To be assigned Displays fuzzy translation proposals in addition to an exact one in the“Translation Memory” window. Is useful for viewing more than one translation possibility for a segment.
Edit abbreviations Translate menu, “Edit abbreviations…” Enables the extension and update of abbreviations defined for the selected language-support file.
Edit addendum terms Spellcheck menu, “Edit addendum terms…” Lets you modify or remove terms which have been added to the spellchecker addendum (for example, terms that have been added by mistake).
Edit an entry in a dictionary Translate menu, “Edit a term…”, or positioning cursor on term in”Dictionary” window and double-clicking mouse button 2 Lets you edit a found entry or add a new one while translating. To edit a multiword term, all components of the term must be marked first.
Look up a sentence in the Translation Memory Options menu, “Sentence lookup…” Looks up a sentence in the Translation Memory while you translate.
Look up a term in a dictionary Translate menu, “Look up a term…”, or positioning cursor on term in”Dictionary” window and double-clicking mouse button 1 Looks up entry of term where the cursor is positioned. To look up a multiword term, all components of the term must be marked first.
Postedit Translate menu, “Postediting” Lets you revise what you translated. Whatever you change in the translation is automatically changed in the Translation Memory.
Spellcheck Spellcheck menu, “File” or “Segment” Checks the spelling of a translated document or an individual segment.
Toggle first character of dictionary proposal Options menu, “Keys…” Changes the first character of the dictionary proposal from uppercase to lowercase, and vice versa. If the dictionary proposal consists of several words, it changes the first character of the word where the cursor is placed. This function does not apply to DBCS characters.
View another document File menu, “Open…” Opens another document for checking purposes while translating. Parts of this document can be marked for copying into the document you currently translate.
View original File menu, “Original window” Displays the source document while translating.
View source of a translation proposal Filemenu, “Source of Proposal”, or double-clicking mouse button 1 while being in proposal window Displays the source of a translation proposal.
View table of contents Cursor menu, “Special go to…” Displays a table of contents of the document being translated. Double-clicking an item directly takes you to this item in the document.To enable the display, you must include a specific tag in your markup table (see classid).
View translation Translate menu, “Show translation” Displays the translation document in HTML, RTF, or Microsoft (R) Word format. Prerequisite is the availability of the WebBrowser control.
View translator’s notes To be assigned Displays the notes for the translator that are contained in the source document.

Manipulating segments

OpenTM2 divides the translation into individual text units (segments). The editor provides functions to conveniently work with these segments.

Task Key or Menu Comment
Compress segment To be assigned Turns segments presented in a style other than compact into compact style again.
Delete segment To be assigned Deletes the active segment.
Expand segment To be assigned Turns a segment into protected style if it was compact before.
Join segments Translate menu, “Join segments” Combines the active segment with the following one, and changes the way a document file is segmented.
Mark segment Key or command to be assigned Marks the active segment.
Reflow segment Edit menu, “Reflow segment” The current segment is reflown (dependent on definition of right margin). This function is not active if right margin is set to AUTO.
Spellcheck segments Spellcheck menu, “Segment” Checks the spelling of a segment.
Split joined segments Translate menu, “Split joined segments” Splits up previously combined segments at the current cursor position.
Translate segment Translate menu, “Translate segment” or Ctrl+Enter Confirms a translation and activates next segment. Alternative way to activate any segment in document where cursor has been positioned. Can be used to leave postediting mode.
Truncate segment Alt+Delete Deletes all text from the current cursor position to the end of the segment.
Untranslate segment Translate menu, “Untranslate segment” Deletes the translated segment from the Translation Memory. The original segment replaces the translated one.

Manipulating documents

The following functions let you save your translation, print it, and leave the Translation Environment. There is also an option to spellcheck the complete translation.

Task Action Comment
End-Save File menu, “End-Save” or F4 Saves the translation and leaves the Translation Environment.
Next File menu, “Next” Toggles between original, translation, and any other open document.
Open File menu, “Open…” Opens another document.
Previous To be assigned Toggles between original, translation, and any other open document in the ring.
Print File menu, “Print” Prints the document displayed in the “Translation”window.
Quit File menu, “Quit” or F3 Closes the Translation Environment and returns you to the Translation Workbench.
Save File menu, “Save” or F2 Saves the translation document.
Spellcheck file Spellcheck menu, “File” Checks the spelling of the document displayed in the “Translation”window.
Spellchecking

To proofread an entire translation document or just a segment, select File… or Segment… from the Spellcheck menu while you are in postediting mode. Click Skip when misspelled words are indicated (in the Misspelled word field) that you consider correct or unimportant.

If a word turns out to be misspelled, either double-click the right word in the Similar words list box or type the correct word in the Change to field and click Change. The misspelled word is then replaced with the correct word.

To permanently add the correct word to the spellchecker, click Addendum. If you want to add this word only temporarily, click Temp add.

This addendum can be edited at a later time. For example, to remove, change, or add more terms.

If no more misspelled words are found, you receive a message.

To practise handling the proofreading aid, refer to the Translator’s Workbook, Lesson 11: Postediting translations.

For more information on spellchecking, refer to Spellchecking a document.

Viewing other documents while translating

If you wish to view another document while translating, select Open… from the File menu.

For a document already imported in OpenTM2, you can specify whether you want to browse the translation or the original. Then select the folder that contains the document from the Folders list. In theDocuments list select the requested document and click Open.

For an external text file, first select the drive where this file is stored and the respective directory from the Directories list. In the Files list select the requested file and click Open to view it.

To leave this window, click Cancel.

Configuring the editor

The following options help you tailor the Translation Environment and make translating easier for you.

Customizing colors and fonts

You can change the font and font size of the text in the various windows of the Translation Environment and the color of the various text types and markup tags to suit your needs.

If you are working with Thai language documents, see Working with Thai language documents for customizing colors and fonts.

To change the font and font size, choose Fonts on the Options menu. This takes you to the “Set Fonts” window on which you can select the window for which you want to change the font and font size. In the Sample text box you see an example of how the changed font looks. When you are satisfied with your changes, click Set to save them. To get the initial settings again, click Defaults.

To change the color, choose Colors on the Options menu. This takes you to the “Set colors” window on which you can select the text type for which you want to change the foreground color, background color, or both. In the Sample text box you see an example of how the changed color looks. When you are satisfied with your changes, click Set to save them. To get the initial settings again, click Defaults.

Refer to the lesson on customizing the Translation Environment in the Translator’s Workbook to learn how to change fonts and colors.

Displaying a ruler

Sometimes it is necessary to position text at a specific place in a translation. For this purpose, OpenTM2 enables you to display a ruler in the “Translation” window or the window that contains the original document or another document. The ruler has the same size as the currently selected font.

To display a ruler in the “Translation” window, select Tailor from the Options menu or the context-sensitive popup menu and choose Ruler. To display a ruler in the window containing the original document or another document, select Tailor from the context-sensitive popup menu and choose Ruler. You get the context-sensitive popup menu by pressing the right mouse button.

Displaying the cursor position

OpenTM2 enables you to display the current position and status of the cursor while you are translating:

Select Tailor from the Options menu or the context-sensitive popup menu and choose Statusbar. In the bottom right corner of your “Translation” window, OpenTM2 displays the following information:

  • Whether you are working in insert or replace mode (Ins or Ins)
  • The number of the segment (Seg) you are currently translating
  • The number of the line (Ln) in which your cursor is positioned
  • The number of the column (Col) at which your cursor is positioned

Setting up the profile

You can customize some translation-specific functions in the editor according to your needs. Do this as follows:

  • Open the Options menu
  • Select Profile settings…

This takes you to the “Customize Translation Functions” window. The options you specify in this window become immediately active when you continue working with OpenTM2.

You can customize the following options:

  • On the “Editor page:
  • Set Insert mode for active segment
If you select this check box, the cursor state is switched to insert mode each time you start translating a new segment, even if it was in replace mode before.
  • Insert proposal if inset mode is active
If you select this check box, a proposal that you copied from the “Translation Memory” window is inserted at the current cursor position when the cursor is in insert mode. When the cursor is in replace mode, and this check box is cleared, the proposal replaces the active segment.
  • Visual display
Determines the display of embedded text in bidirectional language documents. Select this check box if you want embedded numerals and text in an Arabic or Hebrew document to be shown from right to the left. Clear this check box if you want these parts displayed from left to the right. See also Working with bidirectional language documents, if required.
Have this check box cleared also for all non-bidirectional language documents.
  • Automatic insert of SO/SI characters
If you select this check box, shift-in (SI) and shift-out (SO) characters are inserted for double-byte characters (Asian languages).
SO characters and SI characters are treated as protected characters to prevent them from being overtyped. They are still displayed in compact style mode.
  • On the “Display” page:
  • Visible white spaces
If you select this check box, you can select a character that is displayed instead of a blank or a line feed:

  • Visible blank
Select a character from this drop-down list that you want to be displayed instead of a blank.
  • Visible line feed
Select a character from this drop-down list that you want to be displayed instead of a line feed.
Notes:

  1. Some of the selectable characters might not display properly in the active system language.
  2. Do not select the same character for both options, otherwise you cannot distinguish for what the substitution character stands.
  3. You can choose a blank as a substitution for one or the other option. However, choosing a blank for all options causes the Translation Environment to appear as if the check box is not selected. Avoid this combination.
  4. If you use the RTFEdit editor, the selections for Visible blank and Visible line feed are disabled because standard Windows characters are used for both selections.
  • Segment boundary sign in post edit
If you select this check box, you can select a character that is displayed at the end of each segment when you postedit your translation.

  • Segment boundary sign
Select a character from this drop-down list that you want to be displayed at the end ofeach segment.
Note: See also the previous notes.
  • Shrink-style abbreviation
Displays the symbol used as a placeholder for the information that cannot be translated. This symbol is displayed in the “Translation” window if you select the shrink style from the Style menu. You can overtype this symbol with a symbol of your choice. This symbol can consist of up to three characters, for example </>.
  • Compact-style abbreviation
Displays the symbol used to mark information in a segment that cannot be translated. This symbol is displayed in the “Translation” window if you select the compact style from the Style menu. You can overtype it with a symbol of your choice. It can consist of up to three characters, for example </>.
  • Note
Displays the name of the markup tag in the source document indicating that this document contains one or more notes. You can overtype this name with a name of your choice.
  • Line number or active segment
Displays the number of the line containing the active segment. You can change it by specifying a number from 1 to 99.
  • Right margin
Determines the line length of a translated segment. You can select Auto to let the line length automatically adapt to the window size. You can also select one of the offered numbers or specify a number of your choice. This number determines how many characters are to fit a line.
This option only applies to segments still to be translated, not to segments that are already translated.
  • On the “Dictionary” page:
  • Information for dictionary terms
If you mark this option, the “Dictionary” window contains additional information about each dictionary entry. You control which dictionary entry fields are displayed by selecting or deselecting, for each field, the Aut.Lookup check box in the “Dictionary Properties” window. If too many dictionary entry fields are to be displayed, they are abbreviated in the “Dictionary” window.
  • Dictionary terms of all dictionaries
If you mark this option, the “Dictionary” window displays all translations that are found in the folder dictionaries for the terms in the current segment. If you do not mark this option, only the first translation found for the terms is displayed.
  • Dictionary indicator
If you mark this option, the dictionaries listed in the title bar of the “Dictionary” window are numbered. In this case, each translation of a term is preceded by the number of the dictionary from which it comes. The maximum number of dictionaries allowed is 10, where the tenth dictionary is preceded by the letter A.The default color of the dictionary indicator is gray on a white background. You can change these colors in the “Set Colors” window (see Customizing colors and fonts).
  • Show single words of compound terms in auo-lookup
If the option is active the single words of a compound term are looked up together with the compound term. If the option is inactive the single words of a compound term are not looked up in the dictionary auto-lookup.
An example:
Assume a dictionary containing the terms “data”, “data processing”, “data processing unit”, and “unit”. If a segment contains the term “data processing unit” the dictionary window will show the translations for “data”, “data processing”, “data processing unit”, and “unit” if the option is active and “data processing unit” if the option is inactive.
  • On the “Transl.Mem” page:
  • Translation Memory window
Lets you choose how the markup information is to be displayed in this window. You can choose between Protect, Hide, Compact, and Compact+1. Protect is the default. For more information on these styles, refer to How markup tags are displayed.
  • Display ‘Source of Proposal’ window
If you select this check box, the “Source of Proposal(s)” window is always displayed when you work in the Translation Environment. If you clear this check box, the window only appears when you double-click in the “Translation Memory” window, and it disappears again when you continue translating the next segment.
  • Number of proposals
If you select this check box, the number of found translation proposals is displayed in front of the original segment in the “Translation Memory” window and the “Source of Proposal(s)” window. For example, [2] in either of these windows means that two translation proposals are available.
  • Document of proposal
If you select this check box, the file name of the document where a translation proposal originates from is displayed in front of the proposal in the “Translation Memory” window and the “Source of Proposal(s)” window. For example, [DEVICE.HTML] means that the displayed proposal originates from document device.html.
  • Date of proposal
If you select this check box, the date when a translation proposal has been stored in a Translation Memory is displayed in front of the proposal in the “Translation Memory” window and the “Source of Proposal(s)” window. For example, [DEVICE.HTML 3/21/00] means that the displayed proposal has been saved on the date shown.
  • Always display MT match
If you select this check box,, MT matches are always displayed in the “Translation Memory” window. If you clear this check box, MT proposals are only displayed if there are no fuzzy proposals, or fuzzy proposals of poor quality.
  • Automatic replacement in fuzzy matches
If you select this check box, all information that is language independent (and therefore need not be translated), such as dates and proper nouns, is automatically replaced in a fuzzy match to reflect the information in the active original segment. This results in more precise proposals. It also saves you from revising the proposal after it has been copied from the “Translation Memory” window.
This option is particularly useful if you translate documents that contain numerous dates, figures, and abbreviations (for example, stock market reports).
To show the automatic replacement, the proposal is preceded by an [r] when it is displayed in the “Translation Memory” window.
The following example shows an automatic replacement within a fuzzy match:
Current original segment:
(0) - Windows 98 Developer’s Toolkit
Similar segment in a previous original document:
(0) - Windows 95 Developer’s Toolkit
This segment has previously been translated into German:
Windows 95 Entwicklungswerkzeug
If you have not marked this option, you get this translation offered as a proposal in the “Translation Memory” window:
1[f] - Windows 95 Entwicklungswerkzeug
If you have marked this option, the match is presented as follows:
1[r] - Windows 98 Entwicklungswerkzeug
The version number (95) has been updated to match the current original segment.
Note: A translation proposal can be fuzzy in some parts and also contain information that has automatically been replaced (for example, a date). This proposal would be preceded by [rf].
  • Abbreviate Translation Memory proposal
If you select this check box, the original segment in the “Translation Memory” window (preceded by [0]) is truncated if it is longer than one line. This is shown by an ellipsis (…). If this check box is cleared, the “Translation Memory” window displays the complete original segment even if it exceeds one line.
  • Display all exact proposals
If you select this check box, the “Translation Memory” window permanently shows up to nine available translation proposals for a current segment. If multiple proposals are available, they are displayed in chronological order. Proposals from the current document precede those from other documents.
If this check box is cleared, only one (the most recent) translation proposal is displayed for a segment. If more proposals are available, this proposal is preceded by [1++]. You can actuate the display of (up to nine) further proposals by double-clicking ++ in the “Translation Memory” window, or by pressing an assigned shortcut key. However, you need to repeat this for every segment.
  • Quality of Proposal (in %)
If you select this check box, the “Translation Memory” window permanently shows a percentage number with every fuzzy translation proposal. Percentage numbers rank fuzzy proposals; the topmost proposal has the highest rank.
If this check box is cleared, no percentage number is displayed. Nevertheless, the topmost proposal is likely to fit best.
  • On the “Messages” page:
  • Check for changes of inline tags
If you mark this option, OpenTM2 checks if you changed, deleted, or added any markup tags within segments. For example, it checks if you changed a tag that indicates a change of the font type used. If a tag has been changed, you get a warning message. This ensures that the layout of the translation document still looks like that of the original document, and no markup information is changed. If you do not mark this option, the warning message is not displayed.
  • Suppress message ‘Fuzzy proposal unchanged’
If you do not mark this option, you get a warning message when you save a segment that you copied from a fuzzy proposal and did not change it (this is the default). This helps you remember to revise segments that you translated using a fuzzy translation proposal. If you mark this option, the message is not displayed.
  • Suppress message ‘Source unchanged’
If you do not mark this option, you get a warning message when you want to save an untranslated segment as a translation. If you mark this option, the message is omitted, and the original segment is saved as a translation. This might be useful when the original segment contains information that you do not want to translate (for example, citations, time and date information).
  • On the “Aut. Substitution” page:
  • Interrupt automatic substitution
Select this check box if you want the automatic substitution to stop if a segment cannot be substituted automatically. This occurs when OpenTM2 cannot find an exact match in the Translation Memory or if it finds more than one exact match. If you clear this check box, OpenTM2 skips all segments for which no exact match is found or for which more than one exact match is found and continues automatic substitution.
  • Use exact context match when more than one found
Select this check box if you expect segments with more than one exact match in the associated Translation Memory and if you want the system to choose the one from the same document. If you clear this check box, OpenTM2 skips the automatic substitution for this segment whenever more than one exact translation is found for a source segment.
  • Use latest exact match when more than one found
Select this check box if you want an automatic substitution run not to stop when more than one exact match is encountered. The most recent match in the Translation Memory is taken for the substitution.
  • Adjust leading white space to white space in source segment
Select this check box if you want the text to have the same leading white space (blank, tab stop, and line feed) before and after the automatic substitution, or when copying a proposal from the Translation Memory in the active segment.
No adjustment is the default.
  • Adjust trailing white space to white space in source segment
Select this check box if you want the text to have the same trailing white space (blank, tab stop, and line feed) before and after the automatic substitution, or when copying a proposal from the Translation Memory in the active segment.
No adjustment is the default.

Sharing a profile

You may want to provide all translators or those working on the same project with the same profile settings and shortcuts. You can do this in the following way:

  1. Prepare all settings on one workstation.
  2. Stop OpenTM2 on all the workstations to receive the shared profile.
  3. Copy the file eqfprow.prp, which contains all settings, from directory \eqf\property to a diskette or a drive shared among all translators.
  4. Put the copied file in the \eqf\property directory of each translator’s workstation.