Accessibility

Accessibility features help users with physical disabilities, such as restricted mobility or limited vision, to use software products successfully. The following list describes the major accessibility features of OpenTM2:

  • You can use keyboard shortcuts instead of the mouse to perform the most common tasks.
  • You can modify the properties to use colors for the different text types of OpenTM2.
  • You can modify the properties to display different font styles or font sizes.
  • You can assign keys (new, change and/or delete) to almost all available functions OpenTM2 provides to the translator.

The following sections explain how to use these accessibility features.

Contents

[hide]

 

File Menu 1

This table describes the File menu in the main view:

Menu bar choices Actions Keyboard shortcuts
File => Open Opening the ‘Document List’ window from selected folder (works only in the deselected ‘Use Explorer-like tree view’) Alt+O
File => New… Creating

  • a new subfolder (when a file is selected in the ‘Folder List’ window).
  • new folder (when a folder is selected in the ‘Folder List’ window).
  • a translation memory (when ‘Translation Memory’ window is selected).
  • a dictionary (when ‘Dictionary List’ window is selected).
  • a new markup table (when ‘Markup Table List’ window is selected).
  • a new exclusion (when ‘Exclusion Lists’ window is selected).
Alt+N
File => Properties Opening

  • the ‘Folder Properties’ window (when a folder is selected in the ‘Folder List’ window).
  • the ‘Document Properties’ window (when a file is selected in the ‘Folder List’ window).
  • the ‘Translation Memory Properties’ window (when the ‘Translation Memory’ window is selected).
  • the ‘Dictionary Properties’ window (when the ‘Dictionary List’ window is selected).
  • the ‘Markup Table Properties’ window (when the ‘Markup Table List’ window is selected).
Alt+r
File => Properties Summary Opening

  • the ‘Folder Properties Summary’ window (when a folder is selected in the ‘Folder List’ window).
  • the ‘Document Properties Summary’ window (when a file is selected in the ‘Folder List’ window).
  • the ‘Translation Memory Properties Summary’ window (when the ‘Translation Memory’ window is selected).
  • the Dictionary Properties Summary’ window (when the ‘Dictionary List’ window is selected).
Alt+u
File => Delete Deleting the selection (e.g. TM folder, file, memory or dictionary). Alt+D
File => Rename Object Renaming the selected object (e.g. TM folder, memory or dictionary). Alt+b
File => Cut Cutting to the clipboard. —
File => Copy Copying to the clipboard. —
File => Paste Pasting to the clipboard. —
File => Merge… Merging selected translation memory from the ‘Translation Memory List’ window with another selectable memory. Alt+M
File => Organize Organizing selected translation memory or dictionary. Alt+g
File => Analyze… Analyzing the selected OpenTM2 folder. Alt+A
File => Print… Printing the file content opened in the translation view window. Alt+P
File => Print List… Printing the file list of an OpenTM2 folder. Alt+t
File => System Preference Opening the ‘System Preferences’ window. Alt+y
File => Export Exporting selected file (e.g. OpenTM2 folder, file, memory or dictionary). Alt+E
File => Import Importing file (e.g. OpenTM2 folder, file, memory or dictionary). Alt+I
File => Global Find and Replace Opening the ‘Global Find and Replace’ window to find and change a term in all files of a selected folder. Alt+F
File => Select All Selecting all files in a folder. Alt+S
File => Deselect All Deselecting all files in a folder. Alt+l

File Menu 2

This table describes the File menu in the translation view:

Menu bar choices Actions Keyboard shortcuts
File => Translation Environment Selecting one of the file(s) which was/were opened in the translation view. Alt+T
File => Open… Opening another document for checking purposes while translating. Alt+O
File => Save Saving the current file in the translation view. Alt+S
File => Print Printing the current file in the translation view. Alt+P
File => Quit Quitting the current file in the translation view. Alt+Q
File => End-Save Saving and quitting the current file in the translation view. Alt+E
File => Translation Window Bringing the ‘Translation’ window to front. Alt+1
File => Translation Memory Window Bringing the ‘Translation Memory’ window to front. Alt+2
File => Dictionary Window Bringing the ‘Dictionary’ window to front. Alt+3
File => Original Window Bringing the ‘Original’ window to front. Alt+4
File => Source of Proposal Window Bringing the ‘Source of Proposal’ window to front. Alt+5

Colors, fonts and key assignment

In all OpenTM2 versions, you can change the font color, background color and font styles of each segment (translated, untranslated and coded text parts) and proposals. These changes can be performed by the following windows:

  • Translations window
  • Translation Memory window
  • Source of Proposal(s) window
  • Original window
  • Dictionary window

By default, the segments are presented in colors and fonts that can be easily differentiated by color-blind users. For example, most of the color-blind people have difficulties in differentiating between green and red colors. Therefore, these colors were not used as default values.

Set colors

You can modify the default settings by clicking Options => Color… from the menu bar (it is necessary to activate the translation view).
EqfSetColor.gif

Figure 166. Set Colors Window

Set fonts

You can modify the default settings by clicking Options => Fonts… from the menu bar (it is necessary to activate the translation view).
EqfSetFonts.gif

Figure 167. Set Fonts Window

Assign keys

You can modify the default settings by clicking Options => Keys… from the menu bar (it is necessary to activate the translation view).
EqfAssignKeys.gif

Figure 168. Assign Keys Window

Keyboard shortcuts

OpenTM2 provides you can use keyboard shortcuts for the most frequently used tasks. These keyboard shortcuts are described in the following sections.

Opening menus

Task Keyboard shortcut
Moving the focus to the menu bar F10

Navigating in windows (Folder List window, Document List window, Translation Memory List window or Dictionary List window)

Task Keyboard shortcut
Moving the cursor one selection down/up Down/Up arrow
Moving the cursor one screen view down/up Page Down/Up
Moving the cursor to first entry in the window Home
Moving the cursor to last entry in the window End

Default keyboard shortcuts in Translation window

Task Keyboard shortcut
Save F2
Quit F3
End-Save F4
Translation Memory Window F8
Copy Ctrl+c
Paste Ctrl+v
Cut Ctrl+x
Undo Alt+Backspace
Start of Segment Alt+Home
End of Segment Alt+End
Start of Line Home
End of Line End
Start of Segment Alt+Home
End of Segment Alt+End
Translate Segment Ctrl+Newline
Next Untranslated Segment Ctrl+n

Help

Task Keyboard shortcut
Opening the online help F1

Special accessibility keyboard shortcuts

Task Keyboard shortcut
Toggles StickyKeys on and off Tap <SHIFT> 5 times
Toggles FilterKeys on and off Hold the <Right SHIFT> key for 8 seconds
Toggles ToggleKeys on and off Hold the <NUM LOCK> key for 5 seconds
Toggles MouseKeys on and off <Left ALT>+<Left SHIFT>+<NUM LOCK>
Toggles High Contrast on and off <Left ALT>+<Left SHIFT>+<PRINT SCREEN>

Menu bar choices

This chapter summarizes the menu bar choices of OpenTM2. The first five menu items

  • File (Alt+F)
  • View (Alt+V)
  • Utilities (Alt+U)
  • Window (Alt+W)
  • Help (Alt+H)

are visible for all windows.

The following seven menu items are only visible when the translation window is open:

  • File (Alt+F, this File menu contains different choices than the File menu in the main view)
  • Edit (Alt+E)
  • Options (Alt+O)
  • Cursor (Alt+r)
  • Translate (Alt+T)
  • Spellcheck (Alt+p)
  • Style (Alt+l)

As a prerequisite for the Actions described below, the view of OpenTM2 must be set to ‘Use Explorer-like tree view’.

View Menu

Menu bar choices Actions Keyboard shortcuts
View => Name Making only the ‘Name’ Column visible. Alt+N
View => Details Making all selected details visible. Alt+D
View => Change Details… Changing the details view. Alt+C
View => Sort… Opening the ‘Sort List Item’ window. Alt+o
View => Filter… Opening the ‘Filter List Items’ dialog window. Alt+F
View => Show All Showing all files, canceling the filter function. Alt+A
View => Shrink Path Shrinking the path information for all files. —
View => Hide Path Hiding the path information for all files. —
View => Show Path Showing the path information for all files. —
View => Toolbar Selecting one of the following settings:

  • Workbench
  • Translation Environment
  • Status bar
Alt+T

Utilities Menu

Menu bar choices Actions Keyboard shortcuts
Utilities => Count Words… Opening the ‘Count Words’ window (TranslationManger folder or file based). Alt+W
Utilities => Create Counting Report… Opening the ‘Create Counting Report’ window (TranslationManger folder or file based). Alt+R
Utilities => Configure Drives… Configuring drives. Alt+D
Utilities => Connect Shared Resources… Connecting shared resources. Alt+o
Utilities => Build Archive Translation Memory… Building an archive translation memory from the selected folder. Alt+B
Utilities => Display Markup Table List Displaying ‘Markup Table List’ window. Alt+M
Utilities => Display Language List Displaying ‘Language List’ window. Alt+L
Utilities => Display Terminology List Displaying ‘Terminology List’ window. Alt+T
Utilities => Display Machine Translation Job List Displaying ‘Machine Translation Job List’ window. —

Window Menu

Menu bar choices Actions Keyboard shortcuts
Window => Minimize All Minimizing all open windows. Alt+M
Window => Restore All Restoring all active windows. Alt+R
Window => Tile Window Tiling all windows in the OpenTM2 Workbench. Alt+T
Window => Cascade Window Cascading all windows in the OpenTM2 Workbench. Alt+C
Window => 1) Folder List Bringing the ‘Folder List’ window to front. Alt+1
Window => 2) Translation Memory List [Some] Bringing the ‘Translation Memory List [Some]’ window to front. Alt+2
Window => 3) Dictionary List [Some] Bringing the ‘Dictionary List [Some]’ window to front. Alt+3

Help Menu

Menu bar choices Actions Keyboard shortcuts
Help => Help for Help… Opening the ‘Help Topics’ window. Alt+H
Help => Help Index… Opening the ‘OpenTM2 Help’ window. Alt+I
Help => Homepage Opening the TM intranet homepage via standard web browser. Alt+p
Help => Documentation (PDF) Opening the current TM via Acrobat Reader (PDF file format). Alt+D
Help => Documentation (HTML) Opening the current TM via standard web browser (HTML file format). Alt+o
Help => Product Information… Opening the ‘Product Information’ window. Alt+P

Edit Menu

Menu bar choices Actions Keyboard shortcuts
Edit => Find and Replace… Opening the ‘Find and Replace’ window for the ‘Translation’ window. Alt+F
Edit => Cut Cuting to the clipboard. Alt+t
Edit => Copy Copying to the clipboard. Alt+C
Edit => Paste Pasting to the clipboard. Alt+P
Edit => Clear Clearing the selection. Alt+l
Edit => Undo Undoing previous action. Alt+U
Edit => Copy Proposal Block Copying selected proposal block. Alt+o
Edit => Unmark Block Removing marks from text section. Alt+m
Edit => Split Line Splitting the line at the position of cursor. Alt+S
Edit => Join Line Joining the line at the position of cursor. Alt+J
Edit => Line Wrap Setting the wrapping at margin column on or off. Alt+W
Edit => Reflow Segment Reflowing the current segment is reflown (depending on definition of right margin). This function is not active if right margin is set to AUTO. Alt+R

Options Menu

Menu bar choices Actions Keyboard shortcuts
Options => Color… Opening the ‘Set Colors’ window. Alt+C
Options => Fonts… Opening the ‘Set Fonts’ window. Alt+F
Options => Keys… Opening the ‘Assign Keys’ window. Alt+K
Options => Sentence Lookup… Opening the ‘Sentence Lookup’ window. Alt+S
Options => Commands… Opening the ‘Run Command’ window. Alt+o
Options => Profile Settings… Opening the ‘Customize Translation Functions’ window. Alt+P
Options => Tailor Selecting one of the following settings:

  • Ruler
  • Horizontal
  • Vertical
  • Titlebar
  • Status bar
—

Cursor Menu

Menu bar choices Actions Keyboard shortcuts
Cursor => Next Updated Jumping to next updated segment. —
Cursor => Find block Moving cursor to marked text section. Alt+F
Cursor => Special Go To… Opening ‘Special Go To’ window. Alt+p
Cursor => Go to Line… Opening the ‘Go to Line’ window. Alt+G
Cursor => Go to Segment Opening the ‘Go to Segment’ window.
Cursor => Query Line Querying line information of selected line. Alt+Q
Cursor => Top Placing the cursor at the start of the file. Alt+T
Cursor => Bottom Placing the cursor at the end of the file. Alt+B
Cursor => Start of Line Placing the cursor at the start of the line. Alt+S
Cursor => End of Line Placing the cursor at the end of the line. Alt+E
Cursor => Start of Segment Placing the cursor at the start of the segment. Alt+a
Cursor => End of Segment Placing the cursor at the end of the segment. Alt+n

Translation Menu

Menu bar choices Actions Keyboard shortcuts
Translation => Translate Segment Confirming a translation and activating next segment. Alt+T
Translation => Next Untranslated Segment Jumping to next untranslated segment. Alt+N
Translation => Untranslate Segment Deleting the translated segment from translation memory. Alt+U
Translation => Look Up a Term… Opening the ‘Look Up a Term’ window. Alt+L
Translation => Edit a Term… Opening the ‘Edit Entry in Dictionary’ window. Alt+E
Translation => Add an Abbreviation Adding selected word to the abbreviation list. —
Translation => Edit Abbreviations… Editing the abbreviation list. —
Translation => Go To Active Segment Going to active segment. Alt+G
Translation => Join Segments Joining segments. Alt+J
Translation => Split Joined Segments Splitting joined segments. Alt+S
Translation => Set Bookmark Setting a bookmark into the translation window (segmentation based). Alt+B
Translation => Go To Bookmark Going to a created bookmark. Alt+k
Translation => Clear Bookmark Clearing created bookmarks. Alt+C
Translation => Postediting Reviewing the translation and checking the spelling. Alt+P
Translation => Automatic Substitution Copying automatically existing translated segments into the translation document as long as exact matches for the source segments are found. Alt+A
Translation => Show Translation Showing translated file in a preview window. —

Spellcheck Menu

Menu bar choices Actions Keyboard shortcuts
Spellcheck => Segment… Spellchecking the selected segment. Alt+S
Spellcheck => File… Spellchecking the selected file. Alt+F
Spellcheck => Edit Addendum Terms… Opening the ‘Edit Addendum Terms for: …. ‘ window for the target language. —
Spellcheck => Auto Spellcheck Turning the auto spellcheck on or off. Alt+A
Spellcheck => Next Misspelled Jumping to next misspelled word. Alt+N

Style Menu

Only one item can be selected at a time

Menu bar choices Actions Keyboard shortcuts
Style =>– Protect- Unprotect- Hide- Shrink- Compact- Compact+1 Changing the style in the ‘Translation’ window. – Alt+P- Alt+U- Alt+H- Alt+S- Alt+C- Alt+o